Eclipse cannot find Java SDK 1.6 in Mac OS X

- 1 min

Days ago when I tried to write code just for relaxing (I’m going to explain this technique in another article), I had this error message in Eclipse:

image

JVM 1.6.0 disappeared! My first idea was that something happen with the default installation of Java in Mac OS X because manually installed JVM 1.4.2 and JVM 1.5.0 didn’t have any problems.

Searching in the web, I found that from Mac OS X 10.6 Update 3 only JRE will be installed by default and if you want the SDK you have to install the developer package from connect.apple.com (Downloads -> Java):

image

Next step is configure the JVM 1.6.0 because it also changed the installation path.

image

Happy hacking!!!

Abner Ballardo

Abner Ballardo

In permanent beta: learning, adapting and evolving

rss facebook twitter github gitlab youtube mail spotify lastfm instagram linkedin google google-plus pinterest medium vimeo stackoverflow reddit quora quora